Want help with your product upgrades? Upgrades made easy

GFI MailEssentials running on Microsoft Exchange 2013 Service Pack 1 only (Exchange Agents can't be installed)

GFI MailEssentials 2014 SR2 and later fully supports Microsoft Exchange 2013 SP1. However, the latest cumulative update is required to avoid issues with the installation of Exchange agents.

For more information see https://technet.microsoft.com/en-us/library/jj983803(v=exchg.150).aspx